We are currently investigating an issue where calls are not connecting for users on iOS and Android. We have confirmed that calls are working on Web App and Desktop Apps.
Posted Jul 28, 2026 - 11:15 UTC
Investigating
We are currently investigating this issue.
Posted Jul 28, 2026 - 11:11 UTC
This incident affected: Inbound calls and Outbound calls.