Update issues for MAC application

Incident Report for CircleLoop

Identified

We've identified an issue updating to the latest version of the Mac application (v4.21.7) from some of the previous CircleLoop versions.

To work around this issue, please uninstall the Mac application and download the latest version from https://app.circleloop.com/download

You may need to delete the cached data before reinstalling.
Posted Aug 28, 2025 - 09:37 UTC